TEXT 44
321 Guest on 20th December 2022 03:22:03 PM
  1.  
  2. &НаСервере
  3. Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  4.        
  5.         Запрос = Новый Запрос;
  6.         Запрос.Текст =
  7.                 "ВЫБРАТЬ
  8.                 |       Пациенты.Наименование КАК ФИОПациента,
  9.                 |       Пациенты.Email КАК Email
  10.                 |ИЗ
  11.                 |       Справочник.Пациенты КАК Пациенты";
  12.        
  13.         РезультатЗапроса = Запрос.Выполнить().Выгрузить();
  14.         ЗначениеВРеквизитФормы(РезультатЗапроса,"Пациенты");
  15.  
  16.         //ФИОПациента = ЭтаФорма.Параметры.ВыделенныеПациенты;
  17.         //Email = Этаформа.Параметры.ВыделенныеПациенты;  
  18.        
  19.         Таблица = новый таблицаЗначений;
  20.         Таблица.Колонки.Добавить("ФИОПациента");
  21.         Таблица.Колонки.Добавить("Email");
  22.        
  23.         Массив = Этаформа.Параметры.ВыделенныеПациенты;
  24.        
  25.         Для каждого Эл из Массив Цикл
  26.                 НоваяСтрока = Таблица.Добавить();
  27.                 НоваяСтрока.ФИОПациента = Эл.ФИОПациента;
  28.                 НоваяСтрока.Email = Эл.Email;
  29.         КонецЦикла;
  30.         ЗначениеВРеквизитФормы(Таблица,"ВыбранныеПациенты");
  31.  
  32. КонецПроцедуры
  33.  
  34. &НаКлиенте
  35. Процедура Стрелка(Команда)
  36.         Для каждого Эл из Элементы.Пациенты.ВыделенныеСтроки цикл
  37.                 Перенос = 0;
  38.                 СтрокаП = Пациенты.Получить(Эл);
  39.                 Для каждого Элемент из ВыбранныеПациенты цикл
  40.                 Если СтрокаП.Email = Элемент.Email Тогда
  41.                         Перенос = 1;
  42.                 КонецЕсли;
  43.                 КонецЦикла;
  44.     Если Перенос = 0 Тогда
  45.                 НоваяСтрока = ВыбранныеПациенты.Добавить();
  46.                 НоваяСтрока.ФИОПациента = СтрокаП.ФИОПациента;
  47.                 НоваяСтрока.Email = СтрокаП.Email;
  48.         КонецЕсли;
  49.         КонецЦикла;
  50. КонецПроцедуры
  51.  
  52. &НаКлиенте
  53. Процедура Отправить(Команда)
  54.         Массив = новый Массив;
  55.         Для каждого Эл из ВыбранныеПациенты Цикл
  56.                 Массив.Добавить(Эл.Email);
  57.         КонецЦикла;
  58.         Данные = Почта(ПочтаОтправителя);
  59.         РаботаСЭлектроннойПочтой.ОтправитьПисьмоПоЭлектроннойПочте(Массив,Данные,ТекстСообщения);
  60. КонецПроцедуры  
  61.  
  62. &НаСервере
  63. Функция Почта(ПочтаОтправителя)
  64.        
  65.         Данные = Новый Структура ("Email,Пароль,Сервер",ПочтаОтправителя.Наименование, ПочтаОтправителя.Пароль,ПочтаОтправителя.Сервер);
  66.         Возврат(Данные);
  67. КонецФункции

Text Paste is for source code and general debugging text.

Login or Register to edit, delete and keep track of your pastes and more.

Raw Paste

Login or Register to edit or fork this paste. It's free.